nightprowler447

User

Joined on May 11 2016

Savegame Crash
Resolved
Yeah, I get a savegame crash when in Vice City and Liberty City (works well in SA though).
When I save a game, then restart the game and load the save file, then boom, crashes.
LOG

dkluin

Project Leader

Joined on May 11 2016

Posted 4 years ago

The log indicates that you tried to load the savegame whilst already playing. You need to restart the game, on the start menu press New game and then load your savegame from there. If the crash happens on there aswell, then I will really try my best to sort out this strange crash.

nightprowler447

User

Joined on May 11 2016

Posted 4 years ago

Ok dude, I'll try what you said and talk to you later if a crash happens again ;)

dkluin

Project Leader

Joined on May 11 2016

Posted 4 years ago

Alright, I know how to make this crash stop occuring, I just have to NOP all calls to this function which deletes an invalid building and crash will be solved temporarily. It wont unload everything when busted/wasted/loading save though. It's a plus as it could make things run a tiny bit faster, eventually these models will unload properly I hope.

nightprowler447

User

Joined on May 11 2016

Posted 4 years ago

I tried starting the new game then loaded the save file with the new game and still crashed. And, you already solved this crash??

dkluin

Project Leader

Joined on May 11 2016

Posted 4 years ago

Not yet. I can send you a new Underground_Core.asi which could fix the issue soon. Does it make the same crash?

nightprowler447

User

Joined on May 11 2016

Posted 4 years ago

Yeah, same exact crash. When can you send the new ASI? And thanks for noticing and fixing this issue Danny :)

dkluin

Project Leader

Joined on May 11 2016

Posted 4 years ago

No problem, I know what calls this function and I think it's save to disable this function. It can be disabled untill we fix the issue.

Today after I finish my LC bridge issue it will be fixed.